R#5RC - Move command (in Solution Explorer) - Just lost a bunch of code :(

Here's what happened:

I was testing the new Move command on Solution Explorer to move a bunch of files to a different directory whilst preserving namespaces. The first time went well, but after that i started getting a strange behaviour.

Scenario:
- VS 2008
- The solution has 8 projects, all class libraries, all in C#2.0 (targetting 2.0 framework). In total there are hundreds of class files.


Operation:
- In one of the projects, move groups of files to different directories for reorganization purposes. To accomplish this, in Solution EXplorer, i selected the files to move, and right clicked to Refactor -> Move, and selected the destination folder (in the same project), and used the following option:
  - Preserve hierarchy of folders and file names

  - Fix namesspaces
  - To enable Undo, open all files with changes for editing


The files were moved, but then, a lot of files from all projects (i think) were opened and the "Using System" directed was deleted, breaking the code. Annoyingly, since all files were opened, i undo'ed one by one. I also noticed one of the class files being moved, being totally blank. No problem, i thought, undo'ed and still nothing. So i went to SVN and reverted.

Next, i tried again, to see if this happened again, now with a different group of files, but still in the same project as before. Samething happened, a LOT of files were opened in VS with the "Using System" directive deleted. This time i chose, "Close All Files" and didn't save.

Well, the end result was:
- The group of files i tried to move didn't return to it's original folder (expected)
- All these files are blanked and saved. to make matters worse, these files weren't commited yet....

Did i do something wrong ? Is this an known issue ? I'm upgrading to the release version now ...

Cheers

Please sign in to leave a comment.