Slow Typing [Build 351]

Sometime after my project has been loaded and I've been working for a while,
the editor gets very slow to respond to keystrokes.
I'm not sure what triggers this.

A restart eliminates the problem, but unloading and reloading ReSharper from
the add-ins dialog does not.


9 comments
Comment actions Permalink

Can this be similar to your problem?
http://www.jetbrains.net/jira/browse/RSRP-26814

I reported this bug on a much slower computer than I'm using now, but the
problem is still present in recent builds. I ususally just close/reopen form
designers when this bug occurs to get rid of the problem.


"Jeff" <jeffwalsh@hotmail.com> wrote in message
news:<esmjgh$jfr$1@is.intellij.net>...

Sometime after my project has been loaded and I've been working for a
while, the editor gets very slow to respond to keystrokes.
I'm not sure what triggers this.

>

A restart eliminates the problem, but unloading and reloading ReSharper
from the add-ins dialog does not.

>


0
Comment actions Permalink

Hi Dag,
I have the same symptoms you describe in RSRP-26814.
Changing focus on the control in the designer fixes it.
Thanks for the tip - this will save me lots of time.
Jeff

PS This may not be caused by ReSharper. I think it happened one time before
I turned on ReSharper in the Add-ins dialog.

"Dag Christensen" <anonymous@noreply.com> wrote in message
news:esoopt$v3$1@is.intellij.net...

Can this be similar to your problem?
http://www.jetbrains.net/jira/browse/RSRP-26814

>

I reported this bug on a much slower computer than I'm using now, but the
problem is still present in recent builds. I ususally just close/reopen
form designers when this bug occurs to get rid of the problem.

>
>

"Jeff" <jeffwalsh@hotmail.com> wrote in message
news:<esmjgh$jfr$1@is.intellij.net>...

>> Sometime after my project has been loaded and I've been working for a
>> while, the editor gets very slow to respond to keystrokes.
>> I'm not sure what triggers this.
>>
>> A restart eliminates the problem, but unloading and reloading ReSharper
>> from the add-ins dialog does not.
>>
>>



0
Comment actions Permalink

I have the same issue. For me, it is memory consumption. When my project first loads, VS uses about 225MB of memory as seen from the process tab on Task Manager. The memory slowly creeps up while I'm working. After a couple of hours it will be over 600MB or 700MB, which is when I start to notice a response lag to my keystrokes. I just stop and restart VS and I get another few hours to work.

0
Comment actions Permalink

Same problem here, not sure if R# is totally to blame though, but especially after working with some large files, 6,000 lines + (I know, these needs to be re-factored!) the problem is pretty bad, memory consumption gets out of control, even after closing the large files.

0
Comment actions Permalink

I have the same problem which is very annoying. I am using build 5.1.3000.12 and after a while I have to suspend resharper since it becomes terribly slow on every key press. All my four CPUs spike to roof for a few seconds.
I have a solution open with a bunch of class libraries and a winform app, however this problem exists everywhere even if I create a new file with a new class.

0
Comment actions Permalink

Hello Naiem,

Could you please describe your solution (the number of projects, the number
and average size of source files) and your hardware configuration in detail?
Could you please also take a performance snapshot of this behavior (following
the instructions at http://tinyurl.com/6xgxpw5) and upload it to ftp://ftp.intellij.net/.uploads/?
Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have the same problem which is very annoying. I am using build
5.1.3000.12 and after a while I have to suspend resharper since it
becomes terribly slow on every key press. All my four CPUs spike to
roof for a few seconds.

I have a solution open with a bunch of class libraries and a winform
app, however this problem exists everywhere even if I create a new
file with a new class.

---
Original message URL:
http://devnet.jetbrains.net/message/5290830#5290830



0
Comment actions Permalink

Yup, same here. About 5 second lag between keystrokes in VS2010 especially after working with files that are 10,000+ lines of code - don't ask why they're there - they just are. Am running on 2.66Ghz CPU with Solid State Drive and 3.2GB of RAM. Should be lightning-fast but isn't

0
Comment actions Permalink

Noticed that if you turn off "Solution-Wide Analysis" and "Code Analysis" in Resharper->Options then it seems tolerable and doesn't lag as much but then what would be the point of having R#?

0
Comment actions Permalink

Thanx Andrey,

I think I found the problem anyway. There were a bunch of very large .xml files in my solution as Test Resources. Resharper was trying to do something with them.

I have asked resharper to ignore the whole TestResources directory through "Code Ispection"->Settings->"Edit Items to Skip" but it looks like this functionality is not working properly.

The only thing that solved my problem was to physically remove the files from my hard disk (or alternatively remove them from project).

After that, my resharper is not turning my machine into an Ice Cube anymore.

It would be nice if Resharper had a report-like feature that whould show heavy files, so user can optimise basic performance without any profiling, etc.

0

Please sign in to leave a comment.