Missing Tooltip when hover over variables

in the last few builds (currently using 2129) i'm missing the tooltips for variables, methods or constants in the VB and C# editor. Only if i place the cursor on the "." of a method call i see a tooltip showing the declaration of the variable. All other tooltips like the values of constants aren't shown any more.

When i open a file in the editor, the first few seconds when R# starts the analysis of the file, the tooltips are visible. But at latest when the code analysis is ready tooltips aren't displayed anymore.

Additonally i noticed as i opened a second instance of Visual Studio that already opened files in my C# solution wheren't analyzed (no markers on the right side).

Regards
Klaus

4 comments
Comment actions Permalink

Hello Klaus,

Does this happen with any symbols (even if you hover for instance over Console.WriteLine)?
Do you see any exception messages? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

in the last few builds (currently using 2129) i'm missing the tooltips
for variables, methods or constants in the VB and C# editor. Only if i
place the cursor on the "." of a method call i see a tooltip showing
the declaration of the variable. All other tooltips like the values of
constants aren't shown any more.

When i open a file in the editor, the first few seconds when R# starts
the analysis of the file, the tooltips are visible. But at latest when
the code analysis is ready tooltips aren't displayed anymore.

Additonally i noticed as i opened a second instance of Visual Studio
that already opened files in my C# solution wheren't analyzed (no
markers on the right side).

Regards
Klaus
---
Original message URL:
http://devnet.jetbrains.net/message/5300359#5300359



0
Comment actions Permalink

yes, it happens generally. No exceptions are thrown, just no tooltips. If i remember this behavior started somewhere in build 2122 to 2124. I've attached a short video to show you the effect (sorry for the flickering at beginning). The method shown there is the only code in the solution. I also deleted the R# cache before i took the snapshot.

Regards
Klaus



Attachment(s):
sample.7z.zip
0
Comment actions Permalink

Today  i setup a Visual Studio 2010 instance. The tooltip problem seems to be VS 2008 specific.

Regards
Klaus

0
Comment actions Permalink

Hello Andrey,

when do you plan to target this issue? Meanwhile build 2135 is out and the problem still exists.

Regards
Klaus

0

Please sign in to leave a comment.