[RSRP-215013] "Cannot resolve symbol" error with resx files for localized forms where neutral language is not english

Hi.

Resharper 6 highligts a lot of resources.GetString("...") statements  with the error "Can not resolve Symbol" but the resource entry exists in  the resx file.

picture 1 shows the error, picture 2 show the resource entry (pictures are attached to the bug report)

What  I found out so far is, that the error is shown when the english resx  file (en.resx) does not contain this string. However our primary/neutral  language is german.

Adding [assembly: NeutralResourcesLanguageAttribute("de")] to the AssemblyInfo.cs has not helped.

I have create a bug report http://youtrack.jetbrains.net/issue/RSRP-215013?projectKey=RSRP and because I have several thousand error I just wanted to make sure you notice this problem sooner than later. ;)

Kind regards,
Sven

2 comments
Comment actions Permalink

While the bug seems to be not so annoying than before, I can't use the pre-release without a fix.
I have still ~90 files with errors and it seems resharper checks now other resx files than before but still the wrong ones.

I updated the bug entry with a new comment.
For me it seems resharper is looking for the resource entries in the first resx file it founds and not in neutral language ones.
I could remove the error mesages when I added traslations to a cs resx file if it exists or to a en file if no cs exists but an en file exists...

0
Comment actions Permalink

I get a similar problem since Beta 3 see http://youtrack.jetbrains.net/issue/RSRP-273178 for details. Please fix it before release.
As workaround I added disable/restore comments for now.

0

Please sign in to leave a comment.