Can't revert back RS 7.0/RS 6.1

So I tried out ReSharperSetup. but it did not work well at all so I decided to install official release again.

I get vstudio startup error about package not loaded correctly and ReSharper is no longer available when opening a solution.

When I Tried RS 7 repair the installer seems to "hang" while waiting for below to complete:
"C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\DevEnv.exe" /Setup /ResetSkipPkgs
(eating cpu)

So now I'm back to EAP again so I at least can use some RS features. What is the correct way to revert back to the official version?


*Edit: I go to program and features to uninstall ReSharper 7.1 EAP (and it disappears from list of installed program). I then install RS 7.0 (or RS 6.0, this time it went fast, no hanging vstudio.exe) and every time I open vstudio I get 5 nag dialogs with below content and RS does not function any longer (see attached screenshot).
Microsoft Visual Studio
The 'JetBrains.ReSharper.Product.VisualStudio.v10.0.Package, Version=, Culture=neutral, PublicKeyToken=1010a0d8d6380325' package did not load correctly.

The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by running the application together with the /log parameter on the command line, and then examining the file 'C:\Users\MYUSER\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'.

Continue to show this error message?
Yes   No   

1 comment
Comment actions Permalink

I got RS 6.1 working again after uninstalling both TeamCity addin, dotcover and finally RS 7.
Most likely the package loading errors above were caused by "leftovers" in  "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\JetBrains".


Please sign in to leave a comment.