Can we turn off NAnt support in Resharper?

Is there a way to turn off NAnt support in Resharper? My build script is all red due to incorrectly reported errors (other messages posted for each unique error). Can I turn off NAnt support in Resharper until these issues are addressed?

I didn't see anything in options or help.

Thanks,

Sam

5 comments
Comment actions Permalink

Hello Samuel,

You can press Ctrl+8 to turn off code highlighting in your NAnt file. We
try to fix all reported problems in the nearest bugfix release.

Andrew

Is there a way to turn off NAnt support in Resharper? My build script
is all red due to incorrectly reported errors (other messages posted
for each unique error). Can I turn off NAnt support in Resharper
until these issues are addressed?

I didn't see anything in options or help.

Thanks,

Sam



0
Comment actions Permalink

Thanks, Ctrl+8 helps to turn off the highlighting. Intellisense is still on and incorrect which is really the bigger problem..

Best regards,

Sam

0
Comment actions Permalink

Samuel Neff wrote:

Is there a way to turn off NAnt support in Resharper? My build
script is all red due to incorrectly reported errors (other messages
posted for each unique error). Can I turn off NAnt support in
Resharper until these issues are addressed?

I didn't see anything in options or help.


Strange that you have so many problems with NAnt support. We were quite
impressed because all the intellisense, renaming of properties and file
structure view works so well here. Even our own NAnt tasks where
recognized without errors.

We've only had one minor bug with "unknown elements" inside blocks so far, posted here: http://www.intellij.net/tracker/resharper/viewSCR?publicId=25906 Are you running nant rc3 and have you tried to regenerate your NAnt schema file? You can use ]]> and copy the
generated nant.xsd to "C:\Program Files\Microsoft Visual Studio .NET
2003\Common7\Packages\schemas\xml". Not sure if that helps, but thats
one of the less-common things that I did to my NAnt installation.

Max

0
Comment actions Permalink

Hello Markus and Samuel,

We have fixed all of the reported problems as well as the problem with "]]>"
blocks, and it'll be available in the bugfix release.

Thanks,
Andrew

Samuel Neff wrote:

>> Is there a way to turn off NAnt support in Resharper? My build
>> script is all red due to incorrectly reported errors (other messages
>> posted for each unique error). Can I turn off NAnt support in
>> Resharper until these issues are addressed?
>>
>> I didn't see anything in options or help.
>>

Strange that you have so many problems with NAnt support. We were
quite impressed because all the intellisense, renaming of properties
and file structure view works so well here. Even our own NAnt tasks
where recognized without errors.

We've only had one minor bug with "unknown elements" inside <trycatch>
blocks so far, posted here:
http://www.intellij.net/tracker/resharper/viewSCR?publicId=25906

Are you running nant rc3 and have you tried to regenerate your NAnt
schema file? You can use <nantschema output="NAnt.xsd" /> and copy the
generated nant.xsd to "C:\Program Files\Microsoft Visual Studio .NET
2003\Common7\Packages\schemas\xml". Not sure if that helps, but thats
one of the less-common things that I did to my NAnt installation.

Max



0
Comment actions Permalink

Thanks, that's great to hear!

Sam

0

Please sign in to leave a comment.