Autocompletion annoyance in 4.0 beta (possible bug?)

Hi, just wanted to offer a quick bit of feedback. When I press the period key (.) to put in a class member, ReSharper 4 attempts to autocomplete (as it should) but seems to do so asyncronously and with a slight pause, which means that because I'm a reasonably fast typer, if I type the next letter before ReSharper has a chance to pull up the autocomplete list, it cancels the autocompletion altogether, forcing me to either type the whole thing myself (shock horror!) or pressing backspace and retyping to re-initiate the autocomplete and then pausing a moment to allow ReSharper to bring up the autocomplete list.

I find this behaviour quite annoying. It would be nice if ReSharper, when the autocomplete list-retrieval operation returns, it kicks in even if I've started typing. I suspect this is possibly a bug...?

3 comments
Comment actions Permalink

Well, you can always try and get a faster computer :)

Seriously, I encounter the same problem sometimes (especially when first referencing something that does not yet have a using/reference), and it would be nice to have some sort of workaround.

(OTOH, IE7 keeps freezing when I enter messages, and I have to kick off a new tab to get things working again, which is *much* more annoying).

0
Comment actions Permalink

Hello Brian,

Yes, this is a known issue and has been fixed in build 806 (I think). I
will get to Release Candidate which will be published early next week.

WBR,
Oleg Stepanov
Senior Whiteboard Operator
JetBrains, Inc.
"Develop with pleasure!"
mailto:oleg.stepanov@jetbrains.com

Well, you can always try and get a faster computer :)

Seriously, I encounter the same problem sometimes (especially when
first referencing something that does not yet have a using/reference),
and it would be nice to have some sort of workaround.

(OTOH, IE7 keeps freezing when I enter messages, and I have to kick
off a new tab to get things working again, which is *much* more
annoying).



0
Comment actions Permalink

Hello,

(OTOH, IE7 keeps freezing when I enter messages, and I have to kick
off a new tab to get things working again, which is *much* more
annoying).


For posting and reading, you could use the Newsgroups, to which a Web forum
is but a mirror.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.