Sorry for re-post, but can somebody from JetBrains give me some hint?


I am sure I am not the only one who has this question.

When visual studio create some file when I go through wizard, for example,
if I create a linq file (*.dbml) , it will create a *.designer.cs. Resharper
will generate a lot of warnings for this file. (Total 342 warnings for a
single file), Is there any way for me to disable those warnings for the
whole file.

Or , is there any option that I want to disable checking for files with
*.designer.cs, thank you very much.

J.W.

2 comments

JW,

I don't know if you can exclude a complete file or wildcard of files although I seem to remember this has been discussed sometime before. In the short term you could try this if you don't know about it already:

Wrap the code you want to exclude from analysis in a region, say, MyRegion. In RS' options look in the Code Inspection section and select the Settings item. In the Settings you'll see "Generated code regions:", Click the Add button and add your region name MyRegion as a new item. When you look in the code window you should now see that RS will ignore the contents of the region. I think the name you add is case sensitive. Does that help?

0


"Peter Hamilton-Scott" <no_reply@jetbrains.com> wrote in message
news:3134820.54061219302868611.JavaMail.jive@app4.labs.intellij.net...

JW,

>

I don't know if you can exclude a complete file or wildcard of files
although I seem to remember this has been discussed sometime before. In
the short term you could try this if you don't know about it already:

>

Wrap the code you want to exclude from analysis in a region, say,
MyRegion. In RS' options look in the Code Inspection section and select
the Settings item. In the Settings you'll see "Generated code regions:",
Click the Add button and add your region name MyRegion as a new item. When
you look in the code window you should now see that RS will ignore the
contents of the region. I think the name you add is case sensitive. Does
that help?


Thanks, I will try that..

0

Please sign in to leave a comment.