[Reshaper 4.1] Ambiguous Reference incorrect error!

Hello to everybody,
I've got an asp application, each .aspx page inherits from a page called JAPage defined as this way :

public class JaPage : System.Web.UI.Page
public JaPage()

protected override void InitializeCulture()
string lang = String.Format("{0}", Session["Lang"]);
if (!String.IsNullOrEmpty(lang))
Thread.CurrentThread.CurrentUICulture = new CultureInfo(lang);
Thread.CurrentThread.CurrentUICulture = CultureInfo.CurrentUICulture;

When I use it on the aspx pages for example

public partial class Administrator_AdsList : JaPage

I got a red underline....... even on the Administrator_AdsList method I get Methods as Request/Response marked red ....
How To fix It?
Thanks in advance

P.S. : I forgot to say that my Japage.cs is defined inside the App_Code folder (I've got similar problem with all the classes inserted into this folder)

Edited by: Paolo Ponzano on Sep 4, 2008 12:41 PM

Specified More information



>I just installed build 1170 and I'm still getting this error
Unless you provide us with the sample solution, the chances to fix your case
are very low.

I can't believe you're not even attempting to fix this in version 4.1, and
our only recourse is to install nightly builds of 4.5 which is still in
development stages. This is a total showstopper bug and you shouldn't even
be selling 4.1 while this is outstanding.

There's no reason to fix the issue in 4.1 since the upgrade to the 4.5 is
free. Besides that, there are major changes in internal architecture that
make porting the fix back a very complicated task.

Sergey V. Coox
JetBrains, Inc
"Develop with pleasure!"


Hi Sergey,

I have been using 4.5 for a while with no issues and recently (last week or so) started getting this error .  I dont recall I have made any major changes in the app_code directory?

I have tried clearing all temp, clearing reshaper files and reloading everything to no avail.

Is this supposed to be fixed? what else can I look for/try?



I'm also receiving the reference error with 4.5.1274.1.  I've also tried clearing my cache and restarting VS.  It only happens on a few aspx.cs files, but it's super annoying.

// Dave


I updated / was pointed to by support a newer nightly build of - YOUR BUILD!!!!!


And it went away, killed me for weeks it did



Awesome!  I'll give it a shot.


// Dave


hey hey, it appears to have worked!

Thanks again!

// Dave


Please sign in to leave a comment.