ReSharper 5.0 Intellisense VS2010 - Specifying Types on Generics: Typing Issue.

I seem to have an issue with ReSharper 5.0 in Visual Studio 2010 using the ReSharper Intellisense to use generics in my C# code.

When I want to type something like

IList<int> myList = new List<int>();

the ReSharper intellisence will automatically put the '< >' pair around the type argument to the generic as soon as I type the '<' key. I would rather ReSharper's intellisence not do this as it leads to me typing:

IList<int> myList>.....

It appears that ReSharper is not skipping past the auto-inserted '>' character after I finish typing the type that I wish to specify. This forces me to use the right arrow key every time I want to use these types of constructs in my code.

Is there a way to disable ReSharper 5.0 from doing any auto-insertion of '< >' characters? The only workaround I know of is it not use ReSharper's intellisense.

3 comments
Comment actions Permalink

Hello,

Looks like there's no option to turn off autoinsertion of angle brackets.

For most other types of brackets, the typing assist is typing over the closing
bracket (for example, even though typing "()" inserts a closing paren after
you type "(", the typing of ")" that follows overwrites the closing paren.
For angle brackets, this is not available yet :(


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Thanks. I'll await an update to ReSharper that fixes this.

0
Comment actions Permalink

Hello Matthew,

Thanks. I'll await an update to ReSharper that fixes this.


We have added overtyping of closing angle brackets in the type parameters.
This will appear in the next nightly build.

--
Slava Tutushkin
JetBrains, Inc - http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.