Disable tag-match editing

Not sure what the feature is called, but in 5.1 (I think) was added a new feature where if I have <div>...</div> and edit either the beginning or ending div tag it would try to automatically change the corresponding tag. This would be lovely if it worked, but it is hopelessly broken. How can I disable this feature?! Thanks.

6 comments
Comment actions Permalink

Come on guys, isn't there a way to do this? RS is driving me crazy :(

0
Comment actions Permalink

Hi,

What R# build do you have ? I have tested this with the latest release
and all seems to be ok. Please send the screen shot with a wrong
behavior. Thanks!

--
Kirill Falk
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

On 9/18/2010 4:59 AM, pbz wrote:

Come on guys, isn't there a way to do this? RS is driving me crazy :(

>

---
Original message URL: http://devnet.jetbrains.net/message/5272626#5272626



0
Comment actions Permalink

It happens when you have invalid HTML, which can happen quite often when editing / refactoring. See the attached image for an example.Yes, it's invalid HTML, but I'm in the process of fixing it and ReSharper is making it harder on me because it automatically changes a tag somewhere else. When dealing with HTML that fits in the current screen is not such a big problem, although quite annoying, but when the change is out of sight in a big file it can quite painful to hunt down what RS messed up.

I would love to have a way to either disable the whole feature or tell it to only change same-level tags, i.e. if there is any other tag between the currently edited tag and the matched tag don't do anything.

Peter

P.S. I have the latest RS (5.1.1751, reinstalled it to make sure)



Attachment(s):
resharper-tag-match-editing.png
0
Comment actions Permalink

Kirill,

So, is there any hope to be able to disable this "feature"?

Thanks.

0
Avatar
Andrey Serebryansky
Comment actions Permalink

Hello,

I'm afraid there's no way to disable this behavior. We've actually fixed
this problem (see http://youtrack.jetbrains.net/issue/RSRP-188291) and the
fix will be available in one of the future ReSharper releases.

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Kirill,

So, is there any hope to be able to disable this "feature"?

Thanks.

---
Original message URL:
http://devnet.jetbrains.net/message/5273987#5273987



0
Comment actions Permalink

Thanks Andrey, that sounds great, although I would still prefer a way to disable it; just in case it's not really fixed :) (I've been burnt a lot by this one).

0

Please sign in to leave a comment.