Install: Appears to complete successfully but not available in VS2010

I installed ReSharper Beta 6.0.2165.98 and it was working fine.  I updated to 6.0.2168.356 when prompted.  It appeared to install correctly, but ReSharper is now missing from VS2010 (Ultimate Edition).  There is no menu item for ReSharper and it does not appear in Options. It is not in the Extensions Manager and it is not in Help > About.

I ran devenv /Log and I can see no attempt to load anything to do with ReSharper.

I've also installed RC 6.0.2171.226 version with the same result (installation completes with no problems but not available).  Trying to reinstall  ReSharper Beta 6.0.2165.98 doesn't help.

Any ideas of what I can try?


1 comment
Comment actions Permalink

OK, managed to find what was wrong, so hopefully this might help someone else who encounters the same problem.

For some reason the ReSharper folder in the VS2010 Extensions folder was inaccessible to my user (despite the product being installed by this user).  Granting myself access to this folder fixed everything.

On my machine, the folder in question was located in:

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\JetBrains\ReSharper



Please sign in to leave a comment.