How to reset the option to edit readonly files by choosing "Make Writeable"

When refactoring read only files resharper used to prompt with a dialog box that had four options
Edit In-Memory, Make Writeable, Cancel, Help

Unfortunately it had a check box "Don't show this dialog again (Never allow in memory edits)". I accedentally selected this and now I cannot use resharper to edit readonly files. This is frustrating me. Is there any way to bring this dialog back again.

According to this post http://stackoverflow.com/questions/2323310/how-to-reset-the-dont-show-this-dialog-again-settings-for-visual-studio-and-re
The solution is to go in Resharper Options/General and check Always show error dialog when exception occurs.

But I can't find this option in Resharper 5.1 on VS2010.

2 comments
Avatar
Andrey Serebryansky
Comment actions Permalink

Hello Pratik,

That's actually an incorrect solution. The right solution is to open HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\SourceControl
registry key in a registry editor and change the value of 'UncontrolledInMemoryEditDialogSuppressed'
from 1 to 0. Let me know if this helps. Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When refactoring read only files resharper used to prompt with a
dialog box that had four options *Edit In-Memory, Make Writeable,
Cancel, Help*

Unfortunately it had a check box "Don't show this dialog again (Never
allow in memory edits)". I accedentally selected this and now I cannot
use resharper to edit readonly files. This is frustrating me. Is there
any way to bring this dialog back again.

According to this post
http://stackoverflow.com/questions/2323310/how-to-reset-the-dont-show-
this-dialog-again-settings-for-visual-studio-and-re

The solution is to go in Resharper Options/General and check *Always
show error dialog when exception occurs*.

But I can't find this option in Resharper 5.1 on VS2010.

---
Original message URL:
http://devnet.jetbrains.net/message/5269772#5269772



0
Comment actions Permalink

Hi,

I updated the StackOverflow link with a reply that contains a script to fix the problem.

However, is there a way I can suppress the dialog and automatically make documents writeable when I start editing them?

Justification: Version control systems like ClearCase set all files to read-only, and any files that are writable are considered "hijacked" and candidates for "check out".  There is a Visual Studio plug-in for ClearCase, but I don't use it.  The plug-in actually makes using ClearCase more painful.

Do I need to write my own Visual Studio plug-in to handle this dialog interaction?

0

Please sign in to leave a comment.