F6 not giving me context window for "Create class in folder"

I'm using R# 8.0.2

Just a second ago I tried the F6 keyboard shortcut (specified on this doc page: http://www.jetbrains.com/resharper/webhelp/Refactorings__Move__Type_to_Folder.html) to try and generate a class for a non-existing type in my Unit Test and it gave me 3 nice options, one was that create class new folder.  Worked great.

But then later, I tried it again and I get nothing.  An that's what I don't understand.  How could once instance it works and another it does not.

Here's where I'm trying it out, I place my cursor in front of MyNewClass and press F6 and I get nothing now, no helper menu shows now for some reason:

        [TestMethod]
        public void SomeTestBadNameHere()
        {
            // Arrange
            TestClass test = new TestClass

            // Act

            // Assert
            //Assert.IsTrue(iTestClass != null);
        }

So the orange denotes where I've tried to hit F6, orange being my cursor placement.

Any idea why F6 is not working again?

1 comment
Comment actions Permalink

F6 is for moving a class, not creating it. You need to create the type first, with alt+enter, before F6 will move it.

0

Please sign in to leave a comment.