How do I stop Resharper from adding characters to the right of the cursor?

I'm using Resharper with VB.NET in Visual Studio 2010. I don't like it when Resharper adds characters to the right of the cursor. For instance, if I were to type

  Dim x as List(

Resharper would change that to

  Dim x as List(Of )

with the cursor just before the last parenthesis. I like the addition of "Of ", but the addition of the closing parenthesis drives me nuts. I've found that I can disable some of this behavior by unchecking the two "Braces and Parentheses" options under Editor/Editor Behavior. However, Resharper continues to type ahead of the cursor sometimes, such as in the example I gave, and I can't figure out how to turn it off. Can anyone direct me to the appropriate settings?

-TC

2 comments
Comment actions Permalink

Hello TC!

It's know issue - http://youtrack.jetbrains.com/issue/RSRP-287636
You are welcome to comment or vote for it.

Thank you.

0
Comment actions Permalink

Thanks Angelina.
-TC

0

Please sign in to leave a comment.