[Unity] "Assets" suggested for namespace. "Namespace Provider" is false.

Hello!

I just recently discovered ReSharper and I have been using the trial with Visual Studio 2013 and the Unity game engine. It's been great so far, except for one issue that ReSharper continues to suggest that I put "Assets" in my namespace because Unity keeps everything inside an "Assets" folder.

I have selected the Assets folder in Visual Studio 2013 and set the "Namespace Provider" property to false, yet ReSharper continues to suggest I put Assets in my namespace.

Has anyone else had this problem with Unity? Is there any kind of workaround? How would I go about troubleshooting this?
ReShaperAndUnity.png

3 comments
Comment actions Permalink

Hello Garth,

  I filed a new ticket to YouTrack http://youtrack.jetbrains.com/issue/RSRP-421067. You are welcome to track its progress.

Thanks!

0
Comment actions Permalink

Hi. I've just noticed on your screenshot that you have the "Assets" folder of the "Assembly-CSharp-firstpass-vs" project selected, and set "Namespace provider" to false there, but the editor is showing the file from a different project - "Assembly-CSharp-vs". Do you have "Namespace provider" set to false on that project's "Assets" folder too?

0
Comment actions Permalink

Yes. Namespace Provider on Assets is set to false for all three folders Assembly-CSharp-Editor-vs/Assets, Assemply-CSharp-firstpass-vs/Assets, and Assembly-CSharp-vs/Assets. Right clicking all three of those and selecting "Open Folder in File Explorer" brings me to the same folder.

Okay, I just tried some more stuff and I got it working! Microsoft has a free download named "Visual Studio 2013 Tools for Unity" that solved this issue.
http://visualstudiogallery.msdn.microsoft.com/20b80b8c-659b-45ef-96c1-437828fe7cf2
http://unityvs.com/documentation/configuration/

0

Please sign in to leave a comment.