Data Source Configuration Wizard very slow due to ReSharper?

I'm using VS2008 (9.0.30729.1 SP) and ReSharper 7.1.1000.1094. I have a pretty decent system. Windws 7 64, Xeon E3-1240 3.4GHz processor, 16GB ram, RevoDrive (I believe it's an X3 version).

We have a fairly sizeable solution. Around 60 projects. But it's small enough that I can live with the slowness of solution wide analysis. However there is something taking a massive amount of time when I go to the Data Source Configuration Wizard to add a new object data source. The other developer we have working here has the same issue. I think she has solution wide analysis turned off, so that probably isn't related.

I attached a profiler to devenv.exe to figure out why. The first problem seemed to be the Gallio add-on I had installed. Disabling it didn't seem to help. Next thing on the list is apparently a constructor for JetBrains.Application.Threading.MultiCoreFibersPool and it is taking a massive amount of time. And more specifically it's a call to ConcurrentActionQueue.Next() which in turn is calling Monitor.Wait.

I'm just wondering if anyone has had this problem and if there is a solution.I haven't timed it, but I'd guess it takes 5 minutes for the wizard screen to display which is a painfully long time.

2 comments
Comment actions Permalink

The best thing to do is to suspend ReSharper via Tools -> Options -> ReSharper, and then try again. From the description, it doesn't sound like a ReSharper issue - the thread that's sitting in Monitor.Wait is asleep, waiting for something to happen before continuing, so it shouldn't be taking up any CPU activity. If the dialog speed improves when ReSharper is suspended and drops again when resuming ReSharper, then it does look like ReSharper, and you can use the profiling tools built in to ReSharper in the Help menu to capture a trace and send it to us to look into.

0
Comment actions Permalink

I think you may be correct. Disabling ReSharper didn't help much. Guess I'll have to dig into it some more. Thanks.

0

Please sign in to leave a comment.