ReSharper 9.2 formatting options for HTML and Razor are missing (even after reinstall)

ReSharper is applying unwanted formatting behaviours to my Razor and HTML code, but the formatting options for HTML and Razor are completely missing from the ReSharper Options interface. I have uninstalled and reinstalled ReSharper, including removing caches, but the options are still missing.


http://content.screencast.com/users/NathanRidley/folders/Jing/media/f970be2b-5b53-43d3-95dc-0977fb892ad0/2015-08-30_2259.png

3 comments
Comment actions Permalink

Hello Nathan,

  Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\log\resharper_log.txt /ReSharper.LogLevel Verbose'. After that reproduce the issue and send the corresponding 'resharper_log.txt' file to alexander(dot)kurakin(at)jetbrains(dot)com.

Thanks!

0
Comment actions Permalink

Hello Nathan,

  Thanks a lot for the log file.

  Seems like "JavaScript & TypeScript" feature is disabled in R# Options (Environment | Products & Features). For some reason, such checkbox affects HTML/RAZOR settings, I filed a new ticket to YouTrack https://youtrack.jetbrains.com/issue/RSRP-447848.

My apologies for the inconvneince.
Thanks!

0
Comment actions Permalink

Ah, thanks. I have turned JavaScript/TypeScript support back on and you are right, the other options came back. I had disabled JavaScript support earlier, though I can't remember the exact reasons. In general ReSharper was causing my JavaScript development more problems than it solved, though that was 9.1.2, so maybe things have changed. I'll file new issues to that effect if I notice any JavaScript problems.

0

Please sign in to leave a comment.