ReSharper running all tests (not just current session)?

I'm trying to debug a specific nunit test, but it seems ReSharper is running all the tests. My session only contains the one test, but breakpoints get triggered and I can clearly see in the stacktrace they're from another test.

After running, the session still displays just the single test I'm trying to run. I also noticed this when not debugging, for example when running a specific test which would get delayed because of other longer running tests.

Using latest ReSharper v10 with VS2015 and nunit 3.0.0. I tried different variations, starting a fresh session by adding the test, using Run Test, using Debug Test and still the same behavior - while the session window only shows the one test after running, it's clearly running more than just the one I want.

Am I missing something or is this a bug?

11 comments
Comment actions Permalink

Hello Radu,

  Please try installing R# 10.0.2 EAP build https://confluence.jetbrains.com/display/ReSharper/ReSharper+10.0.2+EAP. We fixed similar issues there.

Thanks!

0
Comment actions Permalink

Same problem here,

Using R# Ultimate 2016.2.2 and Machine.Specifications.Runner.Resharper 1.6.0-beta5

It´s running all tests everytime like OP says

0
Comment actions Permalink

Same issue here with latest 2017.3 EAP9 is this a regression bug? Debug runs all, while simple run respects selected cases.

0
Comment actions Permalink

Hello Dmitriy!

 

Sorry for delay in responding.

Could you please check if the problem is reproduced in the latest R# 2017.3.1 https://www.jetbrains.com/resharper/download/

Thank you.

0
Comment actions Permalink

This bug is in 2017.3.3 again?

0
Comment actions Permalink

This same issue is occurring in Visual Studio 2017 Pro (version 15.8.1) with ReSharper Ultimate 2018.2 built on 2018-08-21 with NUnit tests (NUnit version 3.9.0) and a target .NET Framework of 4.6.2. After a reboot of the entire machine, start Visual Studio, open solution, debug any one test, it will work as expected exactly one time. After the test debugging session has stopped, all subsequent debug test instances will attempt to debug all unit tests in the project and running a single unit test will run all unit tests in the project. Closing the test session or all test sessions has no effect. Suspending ReShaper and then resuming ReSharper (using the VS options) has no effect. Closing all instances of VS and starting over has no effect without rebooting the entire machine. Killing JetBrains processes using Task Manager has no effect. Only a reboot allows a single test to be debugged exactly one time and then the problem starts again. I have repeated this process several times. This is not good and needs to be fixed ASAP. Obviously this issue keeps coming back which is not acceptable.

3
Comment actions Permalink

I agree with Wade above, this is happening again.  Please fix this ASAP

0
Comment actions Permalink

Hello!

 

Please try the following build - https://drive.google.com/open?id=14gXwbD9gOGEZYnRtpcrEzL3eDiMU06Bt and check if it helps.

Thank you.

1
Comment actions Permalink

I can confirm that private build solved the issue for me.

0
Comment actions Permalink

Hello Alon!

 

Thank you for the feedback.

The fix will be included in ReSharper 2018.2.1 version.

Thank you.

0
Comment actions Permalink

The build from the link posted above did fix the issue for me as well. It is now working as expected.

 

Thank you,
Wade

0

Please sign in to leave a comment.