ReSharper very slow in core files (5+ second lockup)

Answered

I am developing a reference implemenation web app for my company.  It uses Aurelia with Typescript.

I am finding that if I edit any of the "core" files of the project that resharper locks visual studio up for 5-30 seconds.  This lock up happens after about 5-20 keystrokes.

If I disable resharper, then I can make my edits with no issues.

Currently I just try to remember disable ReSharper before I edit those files.  But I thought I would ask if there is a way to have ReSharper be disabled for specific files.  That way I don't have to wait for it to rebuild the cache when I re-enable it.

So, is there a way to have resharper not be on when in specific files?

For me the files would be:

  • index.htm.
  • main.ts
  • src/app.ts


(Most of the rest of the files work fairly to very well)

I am running:
Visual Studio 2015 Update 1.
Resharper Ultimate 10.0.1

1 comment
Comment actions Permalink

Hello Stephen,

You may try adding such files to "Element to skip" on ReSharper | Options | Code Inspection | Settings page.

By the way, if you notice any problems with performance, could you please help us to determine the cause of the issue by profiling Visual Studio for us - please follow the instructions described here http://resharper-support.jetbrains.com/hc/en-us/articles/214871597-How-to-collect-a-performance-snapshot-and-send-it-JetBrains-Team to collect a snapshot and send it to us. 

Thanks! 

0

Please sign in to leave a comment.