Why does intellisense this?

Answered

I always stumble over a weird behavior of R# intellisense when i work with local variables or lambda expressions. While typing intellisense don't propose the local variable (see screenshot below) until i press Ctrl-Space. For this reason i always get the wrong completion. Is there a setting which prevents this behavior?

6 comments
Comment actions Permalink

Hello Andreas,

Are you able to reproduce the same issue in a demo project? 

Thanks! 

0
Comment actions Permalink

Hi Alexander,

I have checked the behavior with the new R# 2016.3 release and i am able to reproduce it. I created a small demo solution and opened an issue in Youtrack (see https://youtrack.jetbrains.com/issue/RSRP-462280).

Regards

Andreas

0
Comment actions Permalink

Hello Andreas,

Thanks a lot for the solution. Let's make an experiment: please untick ReSharper | Options | Environment | IntelliSense | Completion Filters | Persist filters state checkbox - will it change anything?

Thanks!  

0
Comment actions Permalink

when i uncheck the box, intellisense will work as expected.

 

Regards

Andreas

0
Comment actions Permalink

Awesome! Thanks for confirming. We will have a look what happens when "Persist filters state" checkbox enabled.

Our apologies for the inconvenience. 

0
Comment actions Permalink

hope the next update will come soon :-))

Best Regards

Andraes

0

Please sign in to leave a comment.