Resharper can't recognize class library in same solution?

Answered

As I remember, when class library in same solution, and it's not added as reference in my current project,

 

1. when I type the a class name in that library, resharper WILL ask me if I want to add reference to my current project and add using reference in the class I'm working in. 

2. Or if not automatic, when I click Alt+Enter, there is a option for add reference to my current project and add using reference in the class I'm working in. 

3. Sometime even that doesn't work, I'll manually add the class library in my current project, and then Resharper recognize it and ask me if I want to add using reference in the class I'm working in. 

 

However, currently all above do not work. Any reason why?

 

I have tried restart VS multi times, clean solution multi times, clean resharper cache multi time. Nothing helped. 

 

Any suggestion is welcome, thanks in advance. 

2 comments
Comment actions Permalink

1) What ReSharper build do you use?

2) Are you able to reproduce the same issue in a demo project?

Thanks!  

0
Comment actions Permalink

I'm using 2016.1.2 Resharper. VS 2015 Pro version. 

Unfortunately, the problem come and go, I can't repro this. 

 

After this issue happened a few more times to me, I'm thinking of this always happens after a new project added, and Resharper can't recognize new class in there, even the new project build with no problem. Or maybe happening after moving a class file. 

 

However, I'd thought above occurrence should be fixed by clear Resharper cache and restart VS, but it doesn't fix those. 

 

I just upgraded Resharper to 2016.2.2, hopefully this issue has been magically fixed. 

0

Please sign in to leave a comment.