stop for each auto generating " each As Integer = 0 To 100"

Every time I type for each RS generate an “each As Integer = 0 To 100”. Can't seem to configure this to turn off. 

Thank you


Hello Sam,

Could you please share a screenshot demonstrating the specified behavior?

Thank you.


As soon as I type the E…ach it auto generates. very annoying…..


Hello Sam,


thank you for the info.

According the provided screenshot live template has been entered as it'd been preselected in the completion list during your typing.

I'd suggest the following workarounds: 

1. Disabling completing on Space - ReSharper | Options | Environment | IntelliSense | Completing Characters | VB.NET - Complete on space, though it could affect your experience if you are used to completing items with space.

2. Disabling this specific template in ReSharper | Tools | Templates Explorer | VB.NET | foreach.

Please let me know if neither of these ways works for you.


hello and thank you for your reply.  Unchecking “for” stopped the auto-completion of the loop.


Please sign in to leave a comment.