How do I turn off the nagging notifcation: Configure settings to improve performance

Every time I start Visual Studio 2017 Enterprise (15.5.2), ReSharper Ultimate 2017.3 nags me with a Notification flag : Configure settings to improve performance.

How do I PERMANENTLY suppress that Notification?

Please don't suggest either of the following BECAUSE THEY ARE ONLY TEMPORARY, NOT PERMANENT:

  1. Right click on the Visual Studio notification in the Notifications window and click Always Ignore
  2. Left-click on the ReSharper "Pencil and paper icon" in the bottom-right corner and choose Dismiss all notifications

Again, I am looking for a PERMANENT SOLUTION, so read this post very carefully before you reply.

Additional information:

JetBrains ReSharper Ultimate 2017.3 Build 111.0.20171218.133305
ReSharper 2017.3.20171218.134701

Visual Studio 2017 Enterprise version 15.5.2

16
28 comments

Have you tried opening the main settings, and changing all of them to "Ignore"? It worked for me.

0

Setting all of the entries to Ignore seems to be working.

I have closed and re-opened the same .sln several times and the annoying notification has stopped appearing.

0

Hello Frederick!

 

Sorry for the inconvenience.

Here's corresponding issue reported - https://youtrack.jetbrains.com/issue/RSRP-467729

Please feel free to comment or vote for it.

Thank you.

0

But what if I don't want to ignore some of them? I'm kind of interested in leaving some of them as "Show in Status Bar". I want to know which settings truly are slowing down my system. I'd like to see the little snail pop up in the toolbar to tell me where my problems are. I need a way to tell ReSharper that I've actually reviewed the settings, verified that they are to my liking, and to kindly shut up about it.

6

This is V.Annoying as it suggests that you can ALWAYS IGNORE but it IGNORES your choice. This is a fault.


0

This new "notification" feature has seriously annoyed me to the point, where I am considering getting rid of Resharper. 

7

I've removed resharper and still get the message.  When I click on it I then get:

---------------------------
Microsoft Visual Studio
---------------------------
There was an error while invoking the selected notification.
---------------------------
OK
---------------------------

0

I'm always jumping between branches in my projects which ends up confusing the Visual Studio and ReSharper caches. So, I delete those folders once in a while and then these notifications come back again. I'd love if we could turn off this meta-notification completely. I'd like to see actual performance issue notifications, but not a notification about setting up notifications.

0

I am surprised this is not fixed yet. If you wanted to combat Visual Studio's own notification about ReSharper being slow, you should have done it in a similar way: VS does not show you that notification, unless something really grinds it down to a halt for like 30 seconds in this particular session.

0

This seems to occur in Visual Studio 2019 now.  JetBrains you need to get you act together with these annoyances.  The core Visual Studio can do most the the primary features of ReSharper now, and it is only really product loyalty and comfort (been using ReShaper for almost 15 years) that keeps me subscribed.  But these type of things start to make one question the point of continuing to pay.

4

Getting this in VS 2019 as well and totally agree with Joseph. R# needs to stop slowing down VS so much too otherwise its value becomes more and more questionable as VS itself improves.

0

Is this ever going to be fixed? I'd like to permanently disable this notification without actually setting everything to "ignore".

0

C'mon... Is it so difficult to fix this?

0

In ReSharper 2019.2 EAP https://www.jetbrains.com/resharper/eap/, we've updated the Performance Guide page and now there is a checkbox to enable/disable this suggestion 

 

0

I'm not really sure that is what we need: I don't want to turn of suggestions when there's a new reason to show them; I just don't want to see a generic "tune performance" advice at each start...

0

I've started getting this today - it's really really annoying.

All set to ignore and notification appears every time VS is opened.

 

1

Happening to me also.


JetBrains ReSharper Ultimate 2019.1.3 Build 191.0.20190704.212735

1

It has been 2020 but still same issue and it has not been fixed yet.

 

Please do something about this annoying notification. I am getting it from VS 2019 - ReSharper 2019.3

1

Yea, not a fan of notification nagging.  Please have add a simple option to disable all notifications from ReSharper :)

3

Yep - Totally agree that this is such a frustrating annoyance. Surely it can;t be difficult to fix this. Show a notification ONCE - then when user selects IGNORE/Disimissed - don't show it again!! No need to disable every single notifcation, just honor the fact that the user has seen it - and doesn't need to see it again if Dismissed.

 

I am FED UP of pointless notifications from resharper.

 

2

Hello Markrbaxter,

Where do you select "IGNORE/Disimissed" buttons, in VS notifications window? If so, then, unfortunately, there is no API to figure out this button was clicked.

Therefore, if you'd like not to receive performance notifications, please select Ignore or Fix silently for all options in ReSharper | Options | Environment | Performance Guide or disable all performance suggestions by clearing Enable performance suggestions checkbox. If that doesn't work, please contact us via Submit a request. Thank you!

0

I'm getting notifications for source control plugin, resharper  states if I don't use source control I can turn it off to improve performance, states the setting can only be changed manually (when I click this it takes me to the plug in choice in visual studio to turn it off). There is no option to ignore the notification that I can see and I DO USE SOURCE CONTROL so I don't want to turn the source control plugin off. How do I stop from getting notifications every time I open Visual Studio other than turn "all" notifications off? What is up here JetBrains, Resharper,?

0
Avatar
Angelina Elycheva

Hello W D Wiseman

 

Please set the following option: ReSharper | Options | Environment | Performance Guide | Source Control Plug-in in use to Ignore.

Thank you.

0

It already is set to ignore  Angelina. 

0
Avatar
Angelina Elycheva

Could you please provide all dotSettings files via ``ReSharper | Manage Options | right-click on each layer | Export to file``?

You can upload them using our service - https://uploads.jetbrains.com/.

Thank you.

0

Man, this the SUPER annoying.

0
Hello,
thank you for contacting us.
If you want to disable these notifications, clear the ReSharper | Options | Environment | Performance Guide| Enable performance suggestions checkbox.
Thank you!
1

Thank you for suggestion Olga Rodygina 
Just wanted to add that the checkbox is located at the very top of the “Performance Guide” form. 

0

Please sign in to leave a comment.