Alt Enter not working in VS2017 15.5.2


I'm trying to get Alt+Enter to work in VS2017 15.5.2 Enterprise on my machine.

I tried to reapply the Visual Studio keyboard scheme in R# options and reset Visual Studio's keyboard shortcuts multiple times.

I assigned the Alt+Enter shortcut in the keyboard settings to the ReSharper_AltEnter shortcut entry.


I noticed four things about the AltEnter behaviour:

1.) If I start Visual Studio by opening a solution directly, I can use AltEnter as usual until Visual Studio is fully loaded. So Resharper seems to correctly detect and process the Alt+Enter shortcut while it is loading.

2.) After Visual Studio is fully loaded, everytime I use Alt+Enter I just get the "Enter Action Name: " menu popup, the same  you get if you use "Ctrl+Shift+A" (GoToAction). So despite having set GoToAction and AltEnter to different shortcuts (Ctrl+Shift+A and Alt+Enter respectively) both shortcuts open the same popup menu.

3.) I don't know if this helps but I also noticed that the quick actions shortcut of VS (Ctrl+.) doesn't work if I have ReSharper loaded. I tried to assign Ctrl+. to ReSharper_AltEnter, too, but without any (visible) effect.

4.) I also noticed that AltEnter just doesn't seem to work when editing .cs files (more general if I'm in the code editor) but if I work in the XAML designer view and edit xaml code, the regular AltEnter context menu works just fine.

Is there anything else I can try or is this a known bug? I really would like to use the regular AltEnter context menu again.




Thank you for the feedback.

Sorry for some weird suggestion, but could you please try rebooting your machine and check if the problem is still reproduced.

Thank you.


Thanks Angelina for your fast reply, your suggestion seems to work :)


Suffering from the same problem here, but nothing worked (vs version 15.5.2, resharper 2017.3.1).

UPDATE Working again after updating vs to version 15.5.3.


I'm encoutering this issue now.

I'm on Visual Studio 16.8.4 and Resharper 2020.3.4.

I tried to fix by assigning ReSharper_AltEnter to Alt+Enter globally and verified that it didn't conflict with other shortcut, and it doens't. It definitely doesn't conflict with another resharper keybinding for "Enter Action Name"

This looks like a very nasty bug. Very frustrating. This is so "Yuck".


Hello Sambauwens

Thank you for contacting us! I've replied in the corresponding support ticket.


Please sign in to leave a comment.