"Processing assemblies ..." blocks GUI thread after every build.

My solution contains 51 C++ projects, 20 C# projects and 16 C++/CLI (mixed) projects - some of them are references by .dll (not by project reference).
After every build VS freezes for about 5-50 seconds (more time after each build) - Resharper says "Processing assemblies ...". It doesn't matter how many projects I build (one or whole solution) - it freezes after or sometimes during build. Restart VS helps for short time - after 1-3 builds problem is back.
I don't have Resharper C++ installed (it worked too slow for this solution).

I have this problem in:
Visual Studio 2015 - Visual Studio 2017 (15.3.3).
Resharper 2016.2 - Resharper 2017.2.
Solution is compiled with .NET 4.5.

My PC:
i7 6900K
32 GB RAM (3200MHZ CL14 Quad Channel).
Samsung 960 PRO 512GB
Windows 10

Is it possible to do "Processing assemblies ..." in background (not blocking GUI thread)?

6 comments
Comment actions Permalink

Hello Tomasz!

 

Thank you for the feedback.

Could you please provide R# performance snapshot as described in the following help article - https://resharper-support.jetbrains.com/hc/en-us/articles/207243205

Thank you.

-1
Comment actions Permalink

Done:
https://youtrack.jetbrains.com/issue/RSRP-466452

I think this problem could be reproduced in the following steps:
1. Create 2 projects A, B.
2. In project B add reference to A by ".dll" (from bin directory).
3. Make some changes in A and build the solution.

OR

1. Create project A.
2. Add references to some external assemblies.
3. Replace those assemblies (replace files in directory with differen versions).

More references, projects and builds = longer GUI thread block time.

1
Comment actions Permalink

Is this fixed? I have to disable resharper upon VS shutdown, open VS without R#, then enable R# after starting VS as it blocks the UI and everything lags out terribly. I have a 12 core thread ripper and a PCIE NVME SSD with 3gb/s transfer rates. Why is it still so slow?

2
Comment actions Permalink

Hello Thomas!

 

Thank you for contacting us.

We need to investigate every single case separately.

It will be very helpful if you could provide us performance snapshot as described in the following help article - https://resharper-support.jetbrains.com/hc/en-us/articles/207243205.

Thank you.

-1
Comment actions Permalink

Why does it need to be investigated on a 'per case' basis? Everyone who uses ReSharper will see the "Processing Assemblies..." message at the bottom right of Visual Studio, which pretends it is working on a background thread, but VS is completely unusable until it is completed.

This is not specific to a particular project setup someone might have, and it is happening in every single solution I've worked with in the last year.

Solution with multiple projects, projects can have references to other projects, projects have references to NuGet packages. Build solution. Wait for the "Processing Assemblies" to be done before VS becomes responsive.

 

3
Comment actions Permalink

@Richardnaud is correct. I would like to see a solution.

3

Please sign in to leave a comment.