Resharper 2017.1 EAP8 not running NUnit tests when on .NET Core.


Like I said in the title. Is this expected?

I'm doing Test > Run > All Tests. Build is started but the test runner window does not open.

If this is expected, is there an YouTrack issue on this matter?

Comment actions Permalink
Official comment

Hello Bruno,

"Test > Run > All Tests" is Visual Studio feature, not ReSharper one. 

Anyway, it happens since there is no NUnit test adapter which supports .NET Core projects in VS2017


Comment actions Permalink

Is there an ETA for a fix for this issue? Here is my tooling and R# Test Explorer is not finding any of my nUnit Tests.


Microsoft Visual Studio Professional 2017
Version 15.0.26228.12 D15RTWSVC
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Professional

Visual C# 2017 00369-60000-00001-AA446
Microsoft Visual C# 2017

JetBrains ReSharper Ultimate 2017.1.1 Build 108.0.20170407.122957
JetBrains ReSharper Ultimate package for Microsoft Visual Studio. For more information about ReSharper Ultimate, visit Copyright © 2017 JetBrains, Inc.


ASP.NET and Web Tools 2017 15.0.30223.0
ASP.NET and Web Tools 2017

ASP.NET Web Frameworks and Tools 2017 5.2.50127.0
For additional information, visit

Azure App Service Tools v3.0.0 15.0.30209.0
Azure App Service Tools v3.0.0

JavaScript Language Service 2.0
JavaScript Language Service

JavaScript Project System 2.0
JavaScript Project System

Microsoft Azure Hive Query Language Service 2.2.5000.0
Language service for Hive query

Microsoft Azure Tools 2.9
Microsoft Azure Tools for Microsoft Visual Studio 2017 - v2.9.50131.1

Microsoft MI-Based Debugger 1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Continuous Testing Tool for .NET
Copyright © 2010-2016 Remco Software Ltd

Node.js Tools 1.3.50201.08
Adds support for developing and debugging Node.js apps in Visual Studio

NuGet Package Manager 4.0.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit

SQL Server Data Tools 15.1.61702.140
Microsoft SQL Server Data Tools

ToolWindowHostedEditor 1.0
Hosting json editor into a tool window

TypeScript tools for Visual Studio

Comment actions Permalink

@Kolhapuri Why do you ask about ETA here? NUnit does not support tests in .NET Core projects in VS2017 as I mentioned above, so you are welcome to ask your question there.


Comment actions Permalink

NUnit has preliminary support for tests in .NET Core projects (3.8.0-alpha1 of the adapter). When I use it I can see and run NUnit tests in .NET Core libraries using the VS Test Explorer, but the Resharper Unit Test Explorer does not display (and I assume does not run) those tests. I am able to view and run NUnit tests in a .NET Framework library in both VS and Resharper test explorers.

I posted a comment to that end in the comments of the issue that @Kurakin links above. NUnit says Resharper takes care of interfacing NUnit into Resharper. 

Are there plans on Resharper's side to integrate .NET Core tests into the unit test capabilities?

Comment actions Permalink

Hi Resharper, 

any updates about running nunit on VS2017?

Comment actions Permalink



Please try to install the latest ReSharper EAP build - 

Please let us know if the problem persists.

Thank you.

Comment actions Permalink

I've filed an issue without any response so far: . I wouldn't mind only running non-.NET Core 2 tests (net46 and core 1.1) but now nothing can be run. It would be really nice if this issue could be addressed, Visual Studio's own runner really sucks.

Comment actions Permalink

I solved by installing the Microsoft.NET.Test.Sdk nuget package

Comment actions Permalink

With the most recent stable VS2017 and R# (as of 2018-03-26), you can unit test .net core projects. Make sure you have a netcoreapp2.0 (not netstandard2.0) library project.  Open the project file and make sure the first line is <Project Sdk="Microsoft.NET.Sdk">  Then reference the following 3 nuget packages:


If it still doesn't work, try restarting VS (it's happened a few times where R# including refactoring like CTRL+R+R just dies until restarting VS).

Then each method should be decorated with the (green | yellow) circles.

The only real issue I'm seeing is Explicit tests are running all the time.


Please sign in to leave a comment.