Notes on Compatibility Between dotUltimate Tools

dotUltimate is a set of JetBrains products that includes an IDE and tools for .NET developers (Rider, ReSharper, dotCover, dotTrace, dotMemory, and dotPeek), as well as ReSharper C++ for C++ developers who use Visual Studio.

In late 2014, we have changed the development process for ReSharper tools (ReSharper, ReSharper C++, dotCover, dotTrace, and dotMemory) so that all of them share a set of common assemblies. This helped drastically reduce the memory footprint of ReSharper tools when integrated in Visual Studio, and make Visual Studio much more responsive whenever a combination of these tools was installed.

This change however does have a downside: in order for multiple ReSharper tools to share a set of common assemblies, they have to be of exactly the same version. In practical terms, there is only one combination of versions of ReSharper tools that you can integrate into a single installation of Visual Studio side-by-side. Fortunately, it does not affect Rider, since it is a standalone IDE, which doesn't have any Visual Studio integration.

This is why whenever you download an installer for any ReSharper tool that can be integrated into Visual Studio (ReSharper, ReSharper C++, dotCover, dotTrace or dotMemory), the installer will try to update any other ReSharper tools that it detects in your Visual Studio installation.

For example, if you had ReSharper 2019.3 and dotCover 2019.3 installed and you now run a dotTrace 2020.1 installer, the installer will by default try to update ReSharper and dotCover to version 2020.1 so that their versions match the version of dotTrace that you're trying to install. This behavior might be unwanted for any reason.

Unfortunately, there is no guaranteed solution to this problem. However, there are workarounds available to prevent upgrading existing installations of ReSharper tools when installing or upgrading another ReSharper tool:

  • If you are installing dotPeek, dotTrace or dotMemory, make sure to turn off Visual Studio Integration in the installer: although this will limit the functionality available to you to a certain extent, it is not essential for these tools to be integrated into Visual Studio and they can perfectly operate as standalone applications.
  • If you are installing ReSharper, ReSharper C++ or dotCover — that is, ReSharper tools that require integration with Visual Studio, — the only way to preserve an existing installation is to integrate them into a different version of Visual Studio. For example, if you have an existing installation of ReSharper 2019.3 and dotCover 2019.3 in Visual Studio 2019, and you want to install a recent release of ReSharper C++, consider only integrating ReSharper C++ in Visual Studio 2017 or 2019 Preview.
8 comments
Comment actions Permalink

Frankly speaking I would not expect this from JetBrains. Enforcing users to pay extra for all products in bundle, whereas only one upgrade is required, is hardly a fair play and I have doubts this policy would conform to EU regulations if challenged.

We have 14 Resharper Licenses that we would like to upgrade without waiting for VS2015, whereas we are perfectly fine with existing DotCover functionality, and now it means that we need to pay a grand extra to keep our DotCover working!

2
Comment actions Permalink

This also hits JetBrains.

I am in the market for a new profiler,   I wanted to install and tryout DotTrace.  But it turns out I cannot have both DotTrace installed and my Resharper 8.

I am still going to review it.  But I really NEED Resharper, So it will get a very short review before it gets uninstalled so I can go back to Resharper 8 (I tried just re-installing Resharper 8 and it does not work.)

I am guessing this is an honest bug, but it is a very visible one that impacts existing and prospective customers.

1
Comment actions Permalink

@Glebby Try Out Resharper 9 before you buy it. I am now going back to 8.2.3 as with 9 I had a lot slower user experience in VS and some things are no longer possible. 

0
Comment actions Permalink

I just purchased dotCover 3.0 and there was no warning that this was going to blow away my ReSharper 8.2 installation.  So now what, I'm forced to upgrade ReSharper?  Clever.

-1
Comment actions Permalink

If anyone experiences a problem with uninstalling JB ReSharper Platform from Visual Studio to install a previous version of JB tools, please refer to http://resharper-support.jetbrains.com/entries/92672788-Uninstalling-new-NET-Tools-from-Visual-Studio 

0
Comment actions Permalink

Having Resharper unexpectedly uninstalled when I went to try out dotTrace was a frustrating experience and a waste of my company's time.  It was very time consuming to remove all of the Resharper Ultimate stuff and then reinstall Resharper 8.  Please fix.  You can't expect the customer to know this is going to happen ahead of time.

0
Comment actions Permalink

This is a bit ridiculous.... seems like it would be pretty simple to just enable the "Skip" button in the installer.

0
Comment actions Permalink

So I am confused.  We are licensed for 2016.2.1, we are switching to VS 2017.  Is there a way to continue to use 2016.2.1 with VS 2017, or is it not compatible?

Thanks

JOhn

0

Please sign in to leave a comment.

Have more questions?

Submit a request