ReSharper is not available in Visual Studio after installation

In case ReSharper did not integrate into Visual Studio properly, please follow this guide.

 

I. There's no 'ReSharper' item in Visual Studio main menu

Possible reason: Check if there is "ReSharper" tab in the "Tools | Options" dialog, and ReSharper is not suspended.

  1. If there's no such dialog or it shows an error, continue to the next Part II of this guide (below).
  2. If ReSharper is shown as 'Suspended' in this dialog, use the "Resume" button.
  3. If the page says that ReSharper is not suspended but yet not running, use "Suspend" and then "Resume" button to retry starting the product. You might see the license dialog if there's a problem with licensing, or the "This pre-release build of ReSharper has expired" message. Follow the instructions in these dialogs to resolve the issue.
  4. If there is "The application was requested to shut down with a ShutdownRequested call" message, please follow https://resharper-support.jetbrains.com/hc/en-us/articles/207775459.

II. There's no 'ReSharper'/'ReSharper Ultimate' tab in "Tools | Options" dialog, or it shows an error

  1. Run Visual Studio with /resetskippkgs command line key (e.g. "devenv.exe /resetskippkgs") or delete "HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\{VS_version}.0_Config" branch in Windows registry. 
  2. If '/resetskippkgs' run and deleting the registry branch doesn't help, check if there's folder under '%LocalAppData%\Microsoft\VisualStudio\{VS_version}.0\Extensions\JetBrains\ReSharperPlatformVs{VS_version}' and there are 'extension.vsixmanifest' and 'vspackage.pkgdef' files.
  3. If there are no such files, run 'Repair' on Resharper installation in 'ReSharper Ultimate' installer you used to install ReSharper.   
    • Repairing ReSharper installation can fix integration issues.
  4. If it's still not there and there are some exceptions during repairing process, check http://resharper-support.jetbrains.com/hc/en-us/articles/207243165 and https://resharper-support.jetbrains.com/hc/en-us/articles/206931919 articles about common errors
  5. Run Visual Studio with Local Administrator rights (e.g. 'Run as Administrator').
78 comments
Comment actions Permalink

After latest update R# stopped working in VS17. It is active as an extension, it's shown in menus but it doesn't react on key shortcuts, "goto" doesn't show classes (only history), unit tests are run not by R#,... So basically it completely doesn't work. Reinstall didn't help.

Edited by Victor Yarik
1
Comment actions Permalink

All, I was able to resolve the issue after setting the HKCU\Software\Policy\Microsoft\Windows\Installer\AlwaysInstallElevated registry key to 0.

For more info:

http://upandready.typepad.com/up_and_ready/2012/03/general-systems-windows-7-administrator-tips-tricks.html

Once disabled, the installer prompted for elevated permissions via UAC and the product worked as expected.

Further reading on how to author WiX packages to prompt elevation:

http://blogs.msdn.com/b/astebner/archive/2006/12/13/some-useful-things-i-have-learned-about-windows-installer-and-uac.aspx

1
Comment actions Permalink

Reinstalled from C:\ ,nothing has changed.

0
Comment actions Permalink

Hi, I've come across this error and nothing suggested here helps. I have W7 64 with VS 2013 and R# 8.2 installed and they were working just fine until all of a sudden.. Dude.. where's resharper? From out of the blue, just gone. Gone in the menu but still present in the options page, not disabled there and disable/re-enable doesn't work, reinstall doesn't work (haven't tried reinstalling vs yet as it's a slightly more complicated procedure for me). I wanted to try the checked build but after having created an account with the support site form, I get a Unauthorized on the http://devnet.jetbrains.com/docs/DOC-280 link from above.
Ok.. so what the heck happened? I didn't install anything, there were no VS updates going on. Could it be the patches from Microsoft that came out earlier this day? What do I do now? Do I open a support ticket?

0
Comment actions Permalink

are you running VS as Administrator?

0
Comment actions Permalink

Same problem here, tried every suggestion without any luck, installing R# 8.2.0.2160 on my machine with both VS2013 and 2012 result in no R# menu in VS2012 and a disabled R# menu in VS2013. in both cases option entry is available under Tools->Options menu but stopping/starting R# from button does nothing. No relevant errors reported during install.

Opened request #8737 but got no feedback yet.

0
Comment actions Permalink

Running the repair from the installer fixed it for me.  VS2019, latest update.  R# appeared in the Tools-Options, but with an error.

0
Comment actions Permalink

Can't afford to reinstall entire OS just for R#, support guys can you please support me better on case 8737?

0
Comment actions Permalink

2 Johan Antila & Corrado. What is location you have .msi you installed ReSharper from?   

0
Comment actions Permalink

I have the latest version of Visual Studio 2019 (16.3.6). I generally use Rider, but I wanted to use some of the UI design tools in Visual Studio. To my surprise, ReSharper was no longer present in the main menu bar. Eventually, I found it by clicking "Extensions > ReSharper" (after noticing in "Tools > Options > ReSharper" that I could now access the main menu by pressing "Alt-R"

0
Comment actions Permalink

I have been struggling with this issue for some time (on Windows 8.1), and now that your help above helped me resolve the issue, I'm outlining the steps I took, which are just a collection of steps from above:

  • I completely uninstalled Resharper from 'add and remove programs'..
  • I downloaded Resharper (8.2.1) to c:\download folder (to avoid remote locations)
  • I deleted the %APPDATA%\JetBrains directory
  • I ran cmd (command window) using 'run as Administrator', and went to the c:\download directory
  • I executed msiexec /i ReSharperSetup.x.y.z.w.msi /l*v C:\resharper_install_log.txt

 

0
Comment actions Permalink

Desktop folder, as did with previous upgrades.

0
Comment actions Permalink

It worked. Typing "devenv.exe" in Windows 7--> Start menu, initiated Visual Studio 2015. Then, Resharper license window popped up and was able to activate the 30 day trial (in my case).  Thank you. 

Edited by Ben Q.
0
Comment actions Permalink

I downloaded ReSharperAndToolsPacked01.exe (129 MB). I installed resharper but nothing available

0
Comment actions Permalink

No, as when everything was fine. Even running as admin nothing changes.

0
Comment actions Permalink

Yesterday it was working fine, today it's NOT and after uninstalling, reinstalling 9 times - i give up. I want my money back!

0
Comment actions Permalink

I reinstalled everything from the OS up which was long overdue anyway, everything works as expected after this.

0
Comment actions Permalink

After I run devenv /resetskippkgs VS correctly loads ReSharper, but subsequent restarts of VS2017 don't load ReSharper.

VS2015 loads it fine though.

It's about VS2017 Enterprise 15.3.3

0
Comment actions Permalink

Avatar

 

 

All, I was able to resolve the issue after setting the HKCU\Software\Policy\Microsoft\Windows\Installer\AlwaysInstallElevated registry key to 0.

For more info:

http://upandready.typepad.com/up_and_ready/2012/03/general-systems-windows-7-administrator-tips-tricks.html

Once disabled, the installer prompted for elevated permissions via UAC and the product worked as expected.

Further reading on how to author WiX packages to prompt elevation:

http://blogs.msdn.com/b/astebner/archive/2006/12/13/some-useful-things-i-have-learned-about-windows-installer-and-uac.aspx

 

You are a godsend! I have been trying for a week to get Resharper to load on VS2017 and this solution finally did the trick.  Thanks!

Edited by Ejointer
0
Comment actions Permalink

We cannot install ReSharper 9 with the new Installer because we are not allowed to work as a local administrator, and with the local administrator account it is not possible to install this tool for every user. Please give us some feedback, becaue with ReSharper it worked out perfect.!

 

0
Comment actions Permalink

Nothing works. Still no resharper there, still no menu options. It's like I never existed. And I'm not going to reinstall a developer machine in 8 hours just because Resharper can't perform an install.

0
Comment actions Permalink

I am having the same issue with ReSharper 9 and support will not respond to my messages anymore.  Has anyone got the V9 install to actually work?

0
Comment actions Permalink

this version is working fine ReSharperSetup.8.2.2000.5102.msi but new (ReSharperAndToolsPacked01.exe) doesn't appears

0
Comment actions Permalink

Spoke too soon, it worked once, but has now gone back to not loading.  tried to Repair and it hasn't helped.  Running as admin works, but cant run VS as admin all the time.

0
Comment actions Permalink

Prior to yesterday (before the 9.0 Update 1), I had the 9.0 product working fine. Not anymore. Called them, sent emails nothing so far. the 9.0 installer doesn't work not either - I've installed into a VM and the 9.0 line doesn't work even on a new machine.

0
Comment actions Permalink

 I installed Visual Studio 2012 afterwards and ReSharper was not available ...http://www.asbestosservicesglasgow.co.uk  Visual Studio by simply checking if the ReSharper menu item is available in ... After some digging around,

0
Comment actions Permalink

I think I had R# up and running on my new machine but it doesn't show up in Visual Studio anymore. I'm doing Running VS with /resetskippkgs which didn't help. Also, I don't have {VS_version}.0_Config in Windows registries.

My setup:

  • Visual Studio 2019 Professional
  • JetBrains.ReSharperUltimate.2018.3.4
  • Windows 10

 

Also, why does part II says "Run Visual Studio with /resetskippkgs command line key (e.g. "devenv.exe /resetskippkgs") or delete "HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\{VS_version}.0_Config" branch in Windows registry." and then in the next line it says "If '/resetskippkgs' run and deleting the registry branch doesn't help". Do I have to do both things or one?

0
Comment actions Permalink

With VS16.0.3 , Resharper 2019.1.1 

I ran VS as Administrator,

Extensions->Manage Extensions -> Disable Resharper -> Exit VS

Then repeat as adminstrator this time Enabling Resharper -> Exit VS

Now it works.

Edited by kirsten Greed
0
Comment actions Permalink

I had the same problem. This sequence solved it. Note that ALL commands below were executed as domain administrator:

1) closed every instance of VS2013 and executed devenv.exe /resetskippkgs

2) Loaded VS2013 (as admin, for nothing), and unloaded it

3) Uninstalled Resharper (as admin)

4) reinstalled it with no options (just resharper) from ReSharperAndToolsPacked01 Ver 9.0.exe

 

0

Please sign in to leave a comment.

Have more questions?

Submit a request